[yt-dev] Odd compile, OSX10.6, OMP, x86 vs. i386

david collins antpuncher at gmail.com
Thu Jun 28 15:12:24 PDT 2012

Hi, all--

Sam and I tracked down an odd glitch.  It started with trying to run
the test runner, and I got an error on the "from
yt.utilities.answer_testing.api import" (full trace below)
For some reason the build of yt/utilities/lib/grid_traversal.pyx was
looking for $DEST_DIR/lib64 and not finding it, trying to use
/usr/local/lib/libgomp.dylib which, for some reason is built for i386
rather than x86_64.  Putting /usr/local/lib/x86_64 in LD_LIBRARY_PATH
didn't seem to work, but soft linking /usr/local/lib/x86_64 to
$DEST_DIR/lib64 worked.

More elegant solutions are welcome, but this worked for me.


/run>./test_runner.py --quicksuite=True
Traceback (most recent call last):
  File "./test_runner.py", line 29, in <module>
    from yt.utilities.answer_testing.api import \
  File "/Users/dccollins/local2/src/yt-hg/yt/utilities/answer_testing/__init__.py",
line 26, in <module>
    import runner
  File "/Users/dccollins/local2/src/yt-hg/yt/utilities/answer_testing/runner.py",
line 26, in <module>
    import matplotlib
  File "/Users/dccollins/local2/lib/python2.7/site-packages/matplotlib/__init__.py",
line 133, in <module>
    from matplotlib.rcsetup import (defaultParams,
  File "/Users/dccollins/local2/lib/python2.7/site-packages/matplotlib/rcsetup.py",
line 19, in <module>
    from matplotlib.colors import is_color_like
  File "/Users/dccollins/local2/lib/python2.7/site-packages/matplotlib/colors.py",
line 52, in <module>
    import numpy as np
  File "/Users/dccollins/local2/lib/python2.7/site-packages/numpy/__init__.py",
line 137, in <module>
    import add_newdocs
  File "/Users/dccollins/local2/lib/python2.7/site-packages/numpy/add_newdocs.py",
line 9, in <module>
    from numpy.lib import add_newdoc
  File "/Users/dccollins/local2/lib/python2.7/site-packages/numpy/lib/__init__.py",
line 4, in <module>
    from type_check import *
  File "/Users/dccollins/local2/lib/python2.7/site-packages/numpy/lib/type_check.py",
line 8, in <module>
    import numpy.core.numeric as _nx
  File "/Users/dccollins/local2/lib/python2.7/site-packages/numpy/core/__init__.py",
line 5, in <module>
    import multiarray
ImportError: dlopen(/Users/dccollins/local2/lib/python2.7/site-packages/numpy/core/multiarray.so,
2): no suitable image found.  Did find:
mach-o, but wrong architecture

Sent from my computer.

More information about the yt-dev mailing list